読者です 読者をやめる 読者になる 読者になる

Rails 4.1.8 にしたら chosen が wrong number of arguments (3 for 2) という場合の対処

ruby

Rails 4.1.6 から 4.1.8 にアップデートしたら下記エラーが出た。

wrong number of arguments (3 for 2)
  (in /Users/oooooooo/.rbenv/versions/2.1.5/lib/ruby/gems/2.1.0/gems/chosen-rails-1.2.0/vendor/assets/stylesheets/chosen.css.scss)

とりあえずの対処方法は Which gem is breaking Rails application.css.scss wrong number of arguments 3 for 2 - Stack Overflow にあるけど、sass-rails を 4-0-stable にしておく。

#gem 'sass-rails', '~> 4.0.3'
gem 'sass-rails', github: 'rails/sass-rails', branch: '4-0-stable'

この情報に辿り着くまで時間が掛かったので、同じ目にあっている人のためにメモ。